Geo resolution had no demes

Hi everyone!

I’ve been trying to create a transmission map for my HIV dataset, but got this warning when doing
augur export:

WARNING: Geo resolution “results/traitscountry.mugration_model.txt” had no demes with supplied lat/longs and will be excluded from the exported “geo_resolutions”.

And no map as a result. I’m using “lat-longs.tsv” from Nextstrain documentation.

Could you please assist me in solving this problem?


Hi @CreepyCat,

Can you provide the Augur version and the exact augur export command that you are running?


Hi, @joverlee!

Sure, my Augur version is 24.3.0, and here is the command:

augur export v2 \
  --tree results/tree.nwk \
  --metadata data/metadata_with_mutations.tsv \
  --node-data results/branch_lengths.json \
              results/traits.json \
              results/nt_muts.json \
              results/aa_muts.json \
--geo-resolutions results/traitscountry.mugration_model.txt \
  --colors config/colors.tsv \
  --color-by-metadata subtype country all_mutations \
  --lat-longs config/lat_longs.tsv \
  --output auspice/hiv_mut.json

Best regards,

Ah, the --geo-resolutions does not accept a file. It expects a string of geographic traits to be displayed on the map.

For example, if you want to display region level demes, then use --geo-resolution region.
If you want to the option to change the display between region and country, then use --geo-resolution region country.

1 Like

It’s working!
Thank you very much for your help, Jover!

1 Like