Is this the expected behaviour of augur tree?

Hi all,
I ran this command in the Nextstrain shell:

 Nextstrain  ~/build $ augur tree --alignment nextstrain/geno_3_aligned.fa --output nextstrain/geno_3_tree_raw.nwk

And got this output:

Building a tree via:
	iqtree -ntmax 1 -s nextstrain/geno_3_aligned.fa -m GTR -ninit 2 -n 2 -me 0.05 -nt AUTO -redo > nextstrain/geno_3_aligned.fa
	Nguyen et al: IQ-TREE: A fast and effective stochastic algorithm for estimating maximum likelihood phylogenies.
	Mol. Biol. Evol., 32:268-274.

Is it correct that the ouput of the iqtree command should be piped into the same file as the alignment file?

1 Like

@jonr Thanks for bringing this to our attention. You’ve indeed found a bug due to poor assumptions about filenames in Augur. We’ve been trying to excise those historical assumptions over time, but clearly still have more to fix!

As a workaround for you in the meantime, try renaming your file nextstrain/geno_3_aligned.fa to nextstrain/geno_3_aligned.fasta to get correct behaviour.

For reference, the buggy code is:

I’ve proposed a fix in Fix alignment filename assumptions by tsibley · Pull Request #1206 · nextstrain/augur · GitHub.

Thanks a lot @trs for your help! I just renamed the file to “fasta” and it worked, but I see also your changes to the code have been implemented already.

1 Like