Treetime Error analysis terminated

Dear Community,

I am new to nextstrain. I have some difficulty running my own data. Although I ran the Zika tutorial successfully. When I run my own data I get this message and the analysis stops:

Error in rule refine:
    jobid: 5
    output: results/MENA/tree.nwk, results/MENA/branch_lengths.json
    log: logs/refine_MENA.txt (check log file(s) for error message)

The file shows:
TreeTime.reroot: with method or node: Wuhan/Hu-1/2019
Traceback (most recent call last):
  File "/Users/daliaobeid/miniconda3/envs/nextstrain/bin/augur", line 10, in <module>
  File "/Users/daliaobeid/miniconda3/envs/nextstrain/lib/python3.9/site-packages/augur/", line 10, in main
    return argv[1:] )
  File "/Users/daliaobeid/miniconda3/envs/nextstrain/lib/python3.9/site-packages/augur/", line 75, in run
  File "/Users/daliaobeid/miniconda3/envs/nextstrain/lib/python3.9/site-packages/augur/", line 209, in run
    tt = refine(tree=T, aln=aln, ref=ref, dates=dates, confidence=args.date_confidence,
  File "/Users/daliaobeid/miniconda3/envs/nextstrain/lib/python3.9/site-packages/augur/", line 42, in refine
    tt.clock_filter(reroot=reroot, n_iqd=clock_filter_iqd, plot=False) #use whatever was specified
  File "/Users/dalia/miniconda3/envs/nextstrain/lib/python3.9/site-packages/treetime/", line 345, in clock_filter
    self.reroot(root='least-squares' if reroot=='best' else reroot, covariation=False, clock_rate=fixed_clock_rate)
  File "/Users/dalia/miniconda3/envs/nextstrain/lib/python3.9/site-packages/treetime/", line 471, in reroot
    raise UnknownMethodError('TreeTime.reroot -- ERROR: unsupported rooting mechanisms or root not found')
treetime.UnknownMethodError: TreeTime.reroot -- ERROR: unsupported rooting mechanisms or root not found

Thank you so much in advance,

Hi @obeiddx, welcome! This error most commonly occurs when the requested root—in this case Wuhan/Hu-1/2019—isn’t present in your input data. Looks like you’re running our ncov build with your data? I don’t know what your builds.yaml file looks like, but you can either adjust it to include the standard references or add the references to your own data.

See also other discussion posts related to this same error.

Thank you so much Trs,

The problem was the reference once I included it worked.

Many thanks.