Unsupporting rooting mechanisms or root not found

Hello everyone,

I am very new to Nextstrain and any sort of computer coding in general and I am attempting a test run of only five of our sequences just to learn the ropes. Unfortunately I have been running into many errors, one of which being this:

Error in rule refine:

  • jobid: 5*
  • output: results/north-america_usa_ohio/tree.nwk, results/north-america_usa_ohio/branch_lengths.json*
  • log: logs/refine_north-america_usa_ohio.txt (check log file(s) for error message)*
  • shell:*
  •    *
  •    augur refine             --tree results/north-america_usa_ohio/tree_raw.nwk             --alignment results/north-america_usa_ohio/aligned.fasta             --metadata results/north-america_usa_ohio/metadata_adjusted.tsv.xz             --output-tree results/north-america_usa_ohio/tree.nwk             --output-node-data results/north-america_usa_ohio/branch_lengths.json             --root Wuhan/Hu-1/2019             --timetree                          --clock-rate 0.0008             --clock-std-dev 0.0004             --coalescent skyline             --date-inference marginal             --divergence-unit mutations             --date-confidence             --no-covariance             --clock-filter-iqd 4 2>&1 | tee logs/refine_north-america_usa_ohio.txt*
  •    *
  •    (one of the commands exited with non-zero exit code; note that snakemake uses bash strict mode!)*

Logfile logs/refine_north-america_usa_ohio.txt:
augur refine is using TreeTime version 0.8.1

0.55 TreeTime.reroot: with method or node: Wuhan/Hu-1/2019
Traceback (most recent call last):

  • File “/Users/semi03/Desktop/NextStrain/miniconda3/envs/nextstrain/bin/augur”, line 10, in *
  • sys.exit(main())*
  • File “/Users/semi03/Desktop/NextStrain/miniconda3/envs/nextstrain/lib/python3.8/site-packages/augur/main.py”, line 10, in main*
  • return augur.run( argv[1:] )*
  • File “/Users/semi03/Desktop/NextStrain/miniconda3/envs/nextstrain/lib/python3.8/site-packages/augur/init.py”, line 75, in run*
  • return args.command.run(args)*
  • File “/Users/semi03/Desktop/NextStrain/miniconda3/envs/nextstrain/lib/python3.8/site-packages/augur/refine.py”, line 206, in run*
  • tt = refine(tree=T, aln=aln, ref=ref, dates=dates, confidence=args.date_confidence,*
  • File “/Users/semi03/Desktop/NextStrain/miniconda3/envs/nextstrain/lib/python3.8/site-packages/augur/refine.py”, line 42, in refine*
  • tt.clock_filter(reroot=reroot, n_iqd=clock_filter_iqd, plot=False) #use whatever was specified*
  • File “/Users/semi03/Desktop/NextStrain/miniconda3/envs/nextstrain/lib/python3.8/site-packages/treetime/treetime.py”, line 327, in clock_filter*
  • self.reroot(root=‘least-squares’ if reroot==‘best’ else reroot, covariation=False, clock_rate=fixed_clock_rate)*
  • File “/Users/semi03/Desktop/NextStrain/miniconda3/envs/nextstrain/lib/python3.8/site-packages/treetime/treetime.py”, line 453, in reroot*
  • raise UnknownMethodError(‘TreeTime.reroot – ERROR: unsupported rooting mechanisms or root not found’)*
    treetime.UnknownMethodError: TreeTime.reroot – ERROR: unsupported rooting mechanisms or root not found

I’ve tried tampering with the rule refine in the main workflow but nothing seems to be working. Perhaps this is relevant information or not, but to get where I am I basically edited the example data with my own. Doing this resulted in a few errors saying "all sequences deleted because of region=USA or region= North America. To get around that I deleted all text in front of “exclude” in the paramaters.yaml and it seemed to work until this new error appeared.

Are these errors related? It didn’t seem right to delete all of the exclude parameters but I don’t want anything excluded as I’m only running 5 samples. Of course in the future I will be running hundreds but I’m just trying to learn how to get the system to work.


Your augur refine command is trying to root the tree on sequence Wuhan/Hu-1/2019. My hunch would be that this sequence is not part of your dataset. If not, could you add this sequence (or change the root to a different sequence) and rerun?

Yes augur seemed to be filtering it out because it wasn’t in my metadata. I ran the program again and it worked great! For future sequences if I decided to use a different root, how would I change this?

Otherwise, thanks so much for the help!