Error message when running Zika tutorial workflow

I don’t know how to get past the error message I see when I run the Zika tutorial workflow.

I was able to work it out!

Hi @rania.milleron, I’m glad you were able to resolve your issues! If you are able to, would you be willing to share your approach here? That would help others with the same problem in the future.

– Victor

Hi @rania.milleron, I have the same error. Would you mind if you share your solution? Thanks!

@gej would you be able to share a few more details about your setup so that we can see what the problem might be?

  1. What’s your operating system? Linux/mac/windows
  2. How are you running the workflow? What’s the exact nextstrain command you’re running that results in the problem?
  3. What’s the output of ls -alht in your working directory?

I am following the example on this page, Running a pathogen workflow — Nextstrain documentation.

  1. Ubuntu 22.04 LTS

  2. I followed the example and use the exact same commands. I was able to clone the repository with “git clone GitHub - nextstrain/zika-tutorial: Data and scripts for Zika virus tutorial”. Error show when I run the workflow.

    $ nextstrain build --cpus 1 zika-tutorial/
    Traceback (most recent call last):
      File "/usr/local/bin/snakemake", line 8, in <module>
      File "/usr/local/lib/python3.10/site-packages/snakemake/", line 2957, in main
        success = snakemake(
      File "/usr/local/lib/python3.10/site-packages/snakemake/", line 565, in snakemake
      File "/usr/local/lib/python3.10/site-packages/snakemake/", line 305, in setup_logfile
        os.makedirs(os.path.join(".snakemake", "log"), exist_ok=True)
      File "/usr/local/lib/python3.10/", line 215, in makedirs
        makedirs(head, exist_ok=exist_ok)
      File "/usr/local/lib/python3.10/", line 225, in makedirs
        mkdir(name, mode)
    PermissionError: [Errno 13] Permission denied: '.snakemake'
  3. out of the zika folder:

    $ ls -alht
    total 28K
    drwxrwxr-x  6 gej gej 4.0K Jul 11 11:15 zika-tutorial

    within the zika folder:

    $ ls -alht
    total 40K
    drwxrwxr-x 2 gej gej 4.0K Jul 11 14:07 results
    drwxrwxr-x 6 gej gej 4.0K Jul 11 11:15 .
    drwxrwxr-x 7 gej gej 4.0K Jul 11 10:44 ..
    drwxrwxr-x 2 gej gej 4.0K Jul 11 10:18 data
    drwxrwxr-x 8 gej gej 4.0K Jul 11 08:33 .git
    drwxrwxr-x 2 gej gej 4.0K Jul 11 08:33 config
    -rw-rw-r-- 1 gej gej  517 Jul 11 08:33 .gitignore
    -rw-rw-r-- 1 gej gej  303 Jul 11 08:33
    -rw-rw-r-- 1 gej gej 6.2K Jul 11 08:33 Snakefile

Hi @gej,

Thanks for the information. It looks like Snakemake is having trouble creating the .snakemake directory, even though your gej user has the proper permissions.

To understand the situation better, can you provide the following details?

  1. Output of whoami.
  2. Output of nextstrain version --verbose.
  3. The host machine of your Ubuntu 22.04 LTS. Examples: a Windows computer using WSL, a remote computer, or a local computer with Ubuntu installed directly.

– Victor

It is a local computer with Ubuntu installed directly.

$ whoami
$ nextstrain version --verbose
nextstrain.cli 7.1.0

  3.10.9 (main, Dec 21 2022, 04:02:04) [Clang 14.0.3 ]

  docker (default)
    nextstrain/base:build-20230710T232537Z (a22ca21bf5af, 2023-07-10 16:38:05 -0700 PDT)
    augur 22.1.0
    auspice v2.46.1
    fauna 92b0d7b
    sacra not present

    nextstrain-base unknown

    docker://nextstrain/base (not present)

    augur 14.0.0


Hi @gej,

I tried to reproduce your issue using a new instance of AWS EC2 running Ubuntu 22.04, but everything worked fine. The reason for this error isn’t clear to me, and I’ve asked another teammate to take a look.

In the meantime, can you try using the Conda runtime, and let me know if that works?

nextstrain setup --set-default conda
nextstrain build --cpus 1 zika-tutorial/

– Victor

If you could do this, it will be useful for our investigation. First, start a shell in the Docker runtime:

nextstrain shell --docker zika-tutorial/

Then, copy the output of these commands:

  1. ls -alh
  2. id

Thanks for your cooperation. Hopefully we can understand this issue soon.