Unable to view zika tutorial

We have installed Nextstrain using the documentation available in https://nextstrain.org/ and were able to view the Zika tutorial yesterday.

When we try to visualize the dataset today using this URL - It doesn’t display anything and shows following error.

Please let us know if we miss something here.

Hi @VSUNDARA , could you share more information on how you’ve installed Nextstrain? To better understand the problem, it will be helpful to know what runtime you’re using and what the command line output is when you try to visualize the dataset.

If you’re using the nextstrain command, you can paste the outputs of nextstrain check-setup and the nextstrain view command you’re using to visualize the dataset.

Hi Victor,

Thanks for responding!
I installed by following the documentation in nextstrain website and did the full installation of Nextstrain CLI, Docker, WSL2.
I went to run the pathogen workflow using sample Zika tutorial - Running a pathogen workflow — Nextstrain documentation
Did git clone and got the tutorial without any issues
Ran the workflow using nextstrain build --cpus 1 zika-tutorial/
Visualized it yesterday using nextstrain view zika-tutorial/auspice/ command

When I try to use the same command today in my windows command prompt by entering Nextstrain shell, I see this:

When I click on dataset URL in the documentation which takes me to, I don’t see the workflow.

Here is the nextstrain check results. I see that ambient is the default runtime now but I want it to be docker. So when I try to set docker as default, I get error even though docker engine is running.

Hope you can help!!

I am attaching docker error now as post doesn’t allow more than one.


ok, so I tried setting up the docker as runtime engine in Powershell and it worked however when I check the setup, it still says ambient.

@VSUNDARA Ah, run nextstrain view from outside of the nextstrain shell rather than inside it. Inside of nextstrain shell there you’re running inside an isolated Docker container.

Thanks so much. It worked!!

1 Like

Excellent! Glad to hear it. For reference, we have an open issue tracking this usability quirk and may address it in future versions.