Snakefile not found

I’m trying to run the zika-tutorial from a windows computer (using cygwin) and cannot get past:

Error: no Snakefile found, tried Snakefile, snakefile, workflow/Snakefile, workf

Has anyone had a similar problem? The Snakefile seems completely fine, I can read it and all the tutorial files were downloaded well (I tried both downloading and cloning the repository using git).

Thanks a lot!

Hi @SophieLuiWi, welcome!

This suggests to me that Snakemake ends up running in a different directory than you expect, one that isn’t the zika-tutorial build directory. Two things that would help troubleshoot this:

  1. Can you share the exact command you’re running? It’s essential to know if you’re using the nextstrain build command or running snakemake directly, and what their arguments are.

  2. Can you run pwd (print working directory) in the same place you’re running the build command above and share what it outputs?

I haven’t heard of anyone else using Nextstrain under Cygwin (and I haven’t tried it myself), so let us know how it goes as you proceed!

Hi, thanks a lot!
I followed the steps from the “Quickstart” tutorial and am running this command:

nextstrain build --cpus 1 zika-tutorial/

I am in the same directory as the zika-tutorial folder, which contains the Snakefile. Could there be a problem with the nextstrain setup? When I do “nextstrain check-setup” I get some error messages, but it all end s with “All good”, so I proceeded.

Maybe this screenshot helps:

Thanks a lot! I really appreciate your help!

Hmm. That all looks correct, so I wonder if this is related to Cygwin path handling/munging and its interaction with Docker volume mounts.

Can you run nextstrain shell --exec ls zika-tutorial and share the output?

Sure! The output is:

Entering the Nextstrain build environment

Mapped volumes:
/nextstrain/build is from /cygdrive/c/cygwin/home/sophi/zika-tutorial

Run the command “exit” to leave the build environment.

Hmm. So no additional output from ls? That’s certainly odd, as it appears the volume mapping into the container isn’t working but also isn’t failing/erroring. I suspect something with Cygwin is implicated here, as it’s not an OS/platform we’ve tested on.

No additional output unfortunately. I will update cygwin again and let you know if that’ll fix the problem. Thanks a lot for you help already!