Map not displayed completely

Sorry for raising this question again but the map panel doesn’t show complete view. I can see only the pie charts being displayed on the grey background and no outline of map. I have tried updating auspice as suggested in Map panel not displaying map. But the issue still remains. I even tried what @james suggested in Build with newest nextstrain/ncov has API requests to mapbox 403:Forbidden and I still don’t get the map outlines.

Hi @sreems – are you running auspice locally on your machine through http://localhost:XXXX? Is there anything particular about your setup?

Hi @james
Yes, I am running auspice locally and there is nothing particular about the setup.

I am generating auspice.json file using augur export V2. And trying to locally view the tree using nextstrain view --allow-remote-access --native /path/to/directory/
The tree is visible perfectly. But not the map.

Can you run auspice view --datasetDir /path/to/directory/ and see if this resolves the issue?

(For this to work you’ll need to install auspice itself, but you indicate you’re running the native runtime (--native) so this should already be installed.)

I ran auspice view and still got the map issue.

I am attaching the screenshot of terminal after running the same.

Ok. One final thing to try – can you look in the console of your browser when the map’s not working and see if there are any errors printed? You could also check the network tab and see if map tiles are trying to be loaded and what their status code is. For instance, here’s what it looks like for me (running auspice view on localhost using Firefox):

Hey @james
Thank you so much for troubleshooting this issue with me.
I ran auspice view command and here are the screenshots of my browser console and the network tab.
I see that there are no status codes for any of my tiles. And the console does show some errors.
The error in network shows this message when hovered “the connection used to fetch this resource was not secure”.

I appreciate your help very much.

Those screenshots were super helpful. The map tile addresses are “a.tile.ope…” which indicates you are running a customised version of auspice (perhaps using this guide I wrote?). In this case you’ll have to look into your browser settings and the exact tile-address you are using in your customisation.

P.S. I would expect auspice to work out-of-the-box for you (on localhost) and am happy to debug further if that’s not working.

Thanks for helping me out. I just simply had to change the browser. I was using firefox, and then tried using chrome. It worked perfectly with chrome.

Thanks once again.