Nextclade cli newbie error (windows): Found argument '--input-dataset' which wasn't expected

My first time trying nextclade, I’m using windows.

I ran the dataset get ok and have some files in my data subdir.

Downloaded some sequences in .fasta into my input subdir. I think I’m all set.

Here’s my command line:

nextclade --input-dataset data\sars-cov-2 --output-tsv=output\AUS-2022-07-12.tsv input\AUS-2022-07-12.fasta

But when I tried a run I get this error:
Found argument ‘–input-dataset’ which wasn’t expected, or isn’t valid in this context

Some quirk in the cli syntax for windows?

Hi @mike_honey,

Since version 2.0.0, Nextclade CLI requires a subcommand to be specified (which was optional in versions 1.x.x). In your case it would be run subcommand:

nextclade run --input-dataset data\sars-cov-2 --output-tsv=output\AUS-2022-07-12.tsv input\AUS-2022-07-12.fasta

There was a defect in the documentation, which will be fixed soon. We are also thinking on improving the error message. Right now it’s not very informative.

You can use nextclade --help and similarly, for subcommands nextclade run --help, to obtain the most up to date information on Nextclade arguments.

On Windows, you might or might not need to add .exe extension, .i.e. nextclade.exe.

Windows is the least used platform and we don’t have much feedback from Windows users so far, so any output is valuable. Thank you!