Viewing frequencies in Auspice

What is the output from the ncov tutorial ( “getting started” build supposed to look like? When I run the build defined in my_profiles/getting_started/builds.yaml, it runs with no errors and few warnings (see log files in github repository below), but when I view the resulting auspice/ncov_global.json file in, I don’t see any clade frequencies.

The my_profiles/getting_started/config.yaml file uses the defaults/parameters.yaml file, which specifies the auspice_config file as defaults/auspice_config.json, which includes “frequencies” in the auspice panels.

In auspice, the left-hand panel says “(Frequencies cannot be normalized)”. I’ve tried running several other builds (with builds.yaml and config.yaml files based on “getting_started” and “example” profiles and using data from either example data or data downloaded from GISAID), but none of the builds I’ve run show frequencies in auspice. In all of the builds I’ve tried running so far, Nextstrain does output a file to auspice/ncov_global_tip-frequencies.json. In some of the builds, like the one below, the data contained in the tip-frequencies.json file appear to make sense (see tip-frequencies.png in the repository below. I created the figure in python using the data in auspice/ncov_global_tip-frequencies.json).

Am I doing something wrong? How do I get frequencies to show in auspice?

Link to github repository:
Created using:

git clone ncov_tutorial_example
cd ncov_tutorial_example/
conda activate nextstrain
nextstrain build . --cores 4 --use-conda --configfile 
./my_profiles/getting_started/builds.yaml –forceall

This is a problem with - it cannot display frequencies because it can’t read the sidecar _tip-frequencies.json file.

How do I get frequencies to show in auspice?

If you install auspice or the nextstrain CLI + docker the you can view the datasets locally, including frequencies, via:

# to use auspice directly
auspice view --datasetDir <folder_with_output_JSONs>
# for the nextstrain CLI use
nextstrain view <folder_with_output_JSONs>


First thing first: thank you for this great work!

On my side, I am running a local install (Auspice 2.27.0) and although I included “frequencies” in “panels” list (auspice_config.json) and the “tip-frequencies” JSON is available at the output of Augur 12.0.0 (cf. Adding Frequencies Panel), I am unable to display frequencies panel. “Show frequencies” is even missing from the sidebar (it should be below “Show entropy” as I can see on
What am I missing?

Thank you for your help.

I asked @trs the exact same question. Here is his response:

  • There are two things required for the frequencies panel:
  1. a tip-frequenciessidecar data file
  2. enabling the panel by including "frequencies ​" in the panels ​ section of the Auspice config (see this page, last section). If you’re not using an Auspice config file, you can also use augur export v2 ​’s --panels ​ option

For me I had missed out number 2. Hope that helps, but looks like you have tried this already…


Good point, thank you @dbridges: I modified auspice_config.json inside default/ directory instead of modifying my_auspice_config.json inside my profile directory.

Have a nice day